Sujet résolu
L'auteur a trouvé une solution à son problème.
C’est pas admissible que ça lag comme ça bordel
Voilà ce qu’il faudrait faire, je peux vous aider
- Prévoir des systèmes pour rendre indolore les montées en charge (load balancer etc.)
Par exemple PostgreSQL permet de configurer facilement plusieurs serveurs qui peuvent rapidement prendre le relais si l'un est surchargé https://www.postgresql.or[...]nt/high-availability.html
- Si nécessaire, changer de SGBD (il peut y avoir de grandes différences de latences selon les systèmes utilisés et le type de requêtes nécessaires), en utiliser plusieurs selon leurs avantages / inconvénients, en fonction des requêtes, est aussi une option
- Revoir le code pour l'optimiser
- Convertir le site en SPA / single-page application (ce qui sera plus convivial et évitera de devoir recharger tout le site, mais uniquement les informations nécessaires, comme lors du rafraichissement d'un topic par exemple)
Voilà ce qu’il faudrait faire, je peux vous aider
- Prévoir des systèmes pour rendre indolore les montées en charge (load balancer etc.)
Par exemple PostgreSQL permet de configurer facilement plusieurs serveurs qui peuvent rapidement prendre le relais si l'un est surchargé https://www.postgresql.or[...]nt/high-availability.html
- Si nécessaire, changer de SGBD (il peut y avoir de grandes différences de latences selon les systèmes utilisés et le type de requêtes nécessaires), en utiliser plusieurs selon leurs avantages / inconvénients, en fonction des requêtes, est aussi une option
- Revoir le code pour l'optimiser
- Convertir le site en SPA / single-page application (ce qui sera plus convivial et évitera de devoir recharger tout le site, mais uniquement les informations nécessaires, comme lors du rafraichissement d'un topic par exemple)
il y a 3 ans
Sponsorisé
Connectez-vous pour masquer les pubsrien compris mais si ça peut aider à améliorer le sith je up
¡Esta serpiente marina MATÓ a un Celestino! https://streamable.com/fmjgjb
il y a 3 ans
Pourquoi il y a des erreurs 502 en permanence ?
Les serveurs sont surchargés et mal configurés
il y a 3 ans
Le site est trop sensible au DDOS comptez pas sur cloudfare pour vous en protéger
il y a 3 ans
il vaut mieux prévoir un système comme fail2ban sur Linux et d'autres protections intégrées dans le code du site, car il ne faut pas compter sur Cloudflare pour protéger de la surcharge applicative (HTTP flood, requêtes en DB, etc.)
il y a 3 ans
il vaut mieux prévoir un système comme fail2ban sur Linux et d'autres protections intégrées dans le code du site, car il ne faut pas compter sur Cloudflare pour protéger de la surcharge applicative (HTTP flood, requêtes en DB, etc.)
Comment on procède ensuite ?
il y a 3 ans
Sponsorisé
Connectez-vous pour masquer les pubs

























